Apr
12

New Forum: pkgng Discussion

A new PC-BSD forum has been created: pkgng Discussion. If you have problems installing software using pkgng or running an application installed using pkgng, post the details there so that the developers can fix the issue.

Share This Post:
  • Digg
  • Facebook
  • Twitter
  • email
  • LinkedIn
  • Slashdot

Written by dru. Posted in forums, pkgng

Tags:

Trackback from your site.

Comments (40)

  • April 12, 2013 at 7:43 am |

    Great, Thanks. :)

  • Ken
    April 12, 2013 at 2:18 pm |

    Great improvements recently — thanks.

    I did a reinstall yesterday with fresh 9.1 downloads and solved a number of problems by doing that. A very impressive, new, install process, by the way !

    Only problem now is that Mirrors won’t allow App downloads to finalize at the end of the install process, in App-Cafe. In other words, The download works but won’t complete and a “mirror error message” is given.

    With a new install just made, this leaves me “App’less” — Help !

    Otherwise all looking great :)

    Thanks Team PCBSD !

    * * *

    • April 12, 2013 at 2:49 pm |

      Try changing the mirror in System Manager -> Mirrors (try one or two if the first one doesn’t fix it). If that still doesn’t fix it, let us know.

      • Ken
        April 13, 2013 at 5:40 am |

        Please be more specific as to where that exact Mirror Setup/Manage Menu-box is located, path wise. The one you mentioned is one that I cannot find — - -

        The only reference regarding mirrors is the one in AppCafe at the top of the downloading menu-box. None of the four options of Mirror choice offered there resolve this issue.

        Also, that setup box seems buggy to use.
        Btw, there is no evidence that the mirror selection is working. Suggest the download monitor is uprated to state ” “X-App” is now downloading from “Y” mirror, at “Z” kB/sec ” — - — etc

        Thanks

        * * *

        • Ken
          April 13, 2013 at 6:26 am |

          FURTHER DATA

          The AppCafe Download process is absolutely convinced that the network connection is not present, even though epiphany connects to any website, out of the box. And so it gives the above error — even AFTER the requested Download is already completed correctly !

          This got me to thinking : I have been long convinced that there are too many processes running in 9.1 — sometimes I have seen as many as 490 !

          In short, 9.1 needs to be scanned for old code still in play (not yet removed, and still active)that causes conflicting — and therefore slow/buggy — operation.

          Why I say this is that with this Bug, for example, I found TWO “network settings” boxes, both of which conflict with each other. The Downloader seems programmed to check “Network Established OK” status at the END of the Download (which is itself illogical) and goes off and checks using the old, redundant, incorrect Subroutine for this, instead of the correct, new one.

          The “Network Settings” Menu Box in “System -> Network” is the out-of-date / redundant one in this case. It shows “NO NETWORK CONNECTED”, even though I just read the news at Suzuki or Yahoo .com, using epiphany !

          The “Network Configuration” Box inside the
          “PC-BSD Control Panel” seems to be the new, correct source of info for the Network Connection status.

          The old, seemingly unused — and always incorrect — menu box is stored under “System -> Network”.

          If any App happened to refer to the old one then it would shutdown , illogically of course, due to having received a false picture of reality.

          Funnily enough, both of these “Network Configuration Systems” are right next to each other under “System” — yet both refer to Network Setting or Configurations, totally separately — - -

          *

          Another point here is that there is also the illogicality of checking network presence and status AFTER a download is already complete — that is wild in itself.

          This goes full circle because one of the reasons I reloaded the system was that I observed that when selecting upgrades by clicking on the Upgraded Icon at the top right of the screen, it always appeared to work flawlessly — even when I purposely unplugged the Network cable! This App doesn’t even check network presence at all !

          Logically, a “Network OK and Plausible” process would be called before any Network activity proceeds. Then the user can be made aware of status, ASAP. (There is usually a continuous monitor of Network status running in background, anyway — - — try unplugging the Network cable on Windows and see how fast it warns you !)

          *

          Hope this gives good clues — - -

          • Ken
            April 15, 2013 at 2:03 pm |

            Hi Dru

            This “Mirrors Menu” box is duplicated in the Download Manager and I have tried all of the mirrors there with the same “no result”.

            However, viewing that Downloads Mirror area carefully it appears that it may actually not be working — - -

            While I try this same suggestion again, but instead from the Control Panel area, I would suggest for y’all to check that these two separate, but duplicit, Menu’s call the same SR’s and that they both work as expected.

            Normally both default to “Auto”.

            More soon — - -

            • Ken
              April 15, 2013 at 5:16 pm |

              FURTHER DATA

              Dru — your suggested fix has no effect on the reported Bug.

              1) Whats interesting is that the various Mirror Menu boxes, which are supposed to be the achieving the same Function, all suggest A List of dissimilar URL’s, depending on GUI menu location.

              2) Also, the menu item is called “Repository Mirrors” in the “AppCafe Download Mirror Menu” area. This is a different name to that in the Control Panel Area (here it = “mirrors”).

              These 2 items are further evidence that this major user function about Mirrors is calling different SR’s, depending where it is located in the GUI.

              I would say that’s “Non-Ideal ! This indicates that the programmer may be in the trap of thinking that he was calling “SR-A” but instead is routed through to “SR-B”, which, for example, hasn’t been maintained for years — - — or similar. That redirection remains unknown to the programmer.

              * *

              • April 16, 2013 at 5:54 am |

                Just to be clear, mirrors should be changed in System Manager -> Mirrors. The function in AppCafe reorders repos (which is different) and is usually only used when adding a custom repo.

                There was a slow-down last week with mirrors syncing large changes to pkgng. If a mirror selected in System Manager is not completing the app download, it may be that that particular app has not fully synced on that mirror. If it is still continuing to fail over several mirrors, there may be another issue in play.

                Just to confirm, which PC-BSD installation file did you install from?

              • April 16, 2013 at 12:26 pm |

                I’ve confirmed that this is a bug in the latest RR. The fix is to edit /usr/local/etc/pkg.conf and to change the packagesite line to point to this URL:
                packagesite: ftp://​ftp​.pcbsd​.org/​p​u​b​/​m​i​r​r​o​r​/​p​a​c​k​a​g​e​s​/​9​.​1​-​R​E​L​E​A​S​E​/​a​m​d​64/

                • Ken
                  April 17, 2013 at 1:54 pm |

                  Hi Dru

                  Great news.

                  I went in the there and couldn’t find a “pkg.conf”, exactly. So no fix yet.

                  There were 4 similar filenames :

                  1) pcbsd.conf
                  2) pkgtools.conf
                  3) #2 with a “.sample” suffix
                  4) #2 in red, with the word “status” in the name.

                  Does this mean that I have to create a “pkg.conf”. Or do you mean one of the 4 above, instead ?

                  I changed the Mirrors line in pcbsd.conf by mistake. It formerly pointed to an “xxx.se.yyy” type name. Is that important — if so what should that line have been ? (I should have noted it down).

                  Thanks
                  Ken

                  • April 17, 2013 at 1:57 pm |

                    It sounds like you are on 9.1-release, not rolling release. Can you confirm the name of the file you installed from?

  • Ken
    April 17, 2013 at 2:19 pm |

    Dru — From the URL :

    http://​www​.pcbsd​.org/​e​n​/​d​o​w​n​l​o​a​d​.​h​tml

    The “9.1 64 bit DVD version — - -”

    So that’s not the rolling release version ?
    (Only downloaded it about a week ago and installed afresh, immediately).

    K.

    • April 17, 2013 at 2:23 pm |

      Yes, that’s release and explains why you don’t have a pkg.conf. System Manager -> Mirrors should update /usr/local/etc/pcbsd.conf for you. Mine currently has this mirror set in that file and works OK from the Midwest US:

      PCBSD_MIRROR: ftp://​akane​.desync​.com/​p​u​b​/​p​c​bsd

      If that still doesn’t fix it, we’ll try downloading a PBI from the command line to see what error you’re getting.

  • Ken
    April 17, 2013 at 3:58 pm |

    Dru — It failed with error message = fabulous.

    It reverted to downloading completely (to 100%), THEN halting.

    Error message read :


    pbi-add: Invalid Digital Signature! If U R sure U trust this PBI, reinstall with –no-checksig option

    Happy Sleuthing :)

    K.

    • April 17, 2013 at 4:16 pm |

      Until we figure out the problem (and the fix), go ahead and install what you want using pbi_add –r with that option.

      • April 18, 2013 at 7:18 am |
        • Ken Gibbs
          April 18, 2013 at 3:55 pm |

          The first item ran — I downloaded the file.

          With the second item — the command stalls. It just asks for the “Options” to be filled in properly. No matter what I type, it puts up the instructions screen, U can witness this by typing :


          pbi_delete

          for example.

          My question is : What Options to specify, exactly, for this command ?

          Please test the commands that U sent, in this wise — thanks.

          K.

            • Ken
              April 19, 2013 at 5:19 pm |

              Dru = Same results.

              The commands ran fine — same download halting is occurring. I tried various mirrors under System Manager — - -

              K.

              • April 22, 2013 at 5:39 am |

                This is after downloading and adding the new repo as described above?

                • Ken
                  April 22, 2013 at 11:50 am |

                  Yes.

                  Those commands ran fine — it seemed.

                  • Ken
                    April 25, 2013 at 11:18 am |

                    Dru — Where does this leave us now ?

                    Does the change to github affect this Bug ?

                    Do I have to reinstall the system to make use of github ?

                    Have the system downloads from psbsd​.org been improved yet, so when I download a new system it will incorporate the new changes ?

                    Regards
                    Ken

                    • April 29, 2013 at 12:23 pm |

                      The change to github has no affect as github only affects those users who want to compile things prior to them being incorporated.

                      The mirror subsystem is still being worked on and there should be a vast improvement over the next week or so.

                    • Ken
                      May 1, 2013 at 10:03 am |

                      Excellent :)

                    • Ken
                      May 1, 2013 at 1:33 pm |

                      To re-mention one other Mirror type Bug ;

                      1) With the recent reinstall I did (about a month ago), a new icon at the top right hand side of the screen shows Internet connection status. This feature is working well and “immediately” reports when the Ethernet line is disconnected.

                      However, the “Check Upgrades” process will run to completion irrespective of the state of the Ethernet connection. This is illogical — please fix !

                      Regards
                      Ken

                    • Ken
                      May 1, 2013 at 4:56 pm |

                      Another useful feature (which may already be in place) is the verification of the accuracy of any upgrade or .pbi files that download, through the use of checksum routines etc.

                      Such a feature will help maintain system integrity, in a big way — - -

                      *

                      K.

                    • Ken
                      May 16, 2013 at 5:25 am |

                      Hi Dru

                      The system is still as unusable as it always was, due to the Mirror bug.

                      Should I reload the operating system ?

                    • May 17, 2013 at 6:58 am |

                      We apologize that it is taking so long to get the mirrors sorted. We hope everything is back to normal within another week. You could try waiting another week, try a reinstall, or see if the next rolling release works better for you–it will be available next week, assuming the mirrors are good.

                    • Ken
                      May 17, 2013 at 10:06 am |

                      Perfect — I lose access to a Win-7 loaner PC in 2 weeks (good timing !).

                      Wanna return to the most user-friendly system that there is = PC-BSD :)

                      Thanks !

                    • Ken
                      June 19, 2013 at 11:21 am |

                      Hi Dru & Co

                      How is the Mirror upgrade progress proceeding ?

                      No changes to the situation obvious at this end.

                      Regards
                      Ken

                      * * *

                    • June 20, 2013 at 5:16 am |

                      These should be working now. Can you start a new comment thread (more writing room) with a summary of which version you’re running now and the error you’re getting?

  • bird
    May 11, 2013 at 12:26 am |

    A few days i am not able update packages. Result is :
    Normal Line: “FETCH: /packages/9.1-RELEASE-p3/amd64/All/clucene-2.3.3.4_2.txz”

    Of course there is no 9.1-RELEASE-p3 directory on update servers. How can I fix it?

    Thx.

    Sorry for my bad english.

    • May 15, 2013 at 6:34 am |

      Please paste the command you are using to update packages.

      • bird
        May 15, 2013 at 7:08 am |

        1. uname –a
        FreeBSD pcbsd-7163 9.1-RELEASE-p3 FreeBSD 9.1-RELEASE-p3 #0: Mon Apr 29 18:27:25 UTC 2013 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64

        2.command was : pc-updatemanager pkgupdate

        3. Problem had been solved with commands :

        /usr/home/bird# pkg update
        /usr/home/bird# pkg upgrade

        After that the pc-updatemanager /GUI/ is ok and all packages was upgraded.

        Thx.

  • Ken
    June 21, 2013 at 3:06 am |

    Hi Dru

    Yes — the situation remains the same, as above, so far.

    Info : 9.1 Release amd-64

    Whenever I go to AppCafe to download Apps the Download begins, then after a delay it reports “Error in Download — check Mirror or Network”.

    Therefore no Download occurs and so I have to cancel the Download.

    *

    Following the advices of the error message :

    1) Check Mirrors and Repositories : These are both set to “Official BSD”, etc.

    2) Check Network :

    Here there are peculiarities, as previously described under this Forum title.

    The Icon at the top right of the screen concerning the Ethernet connection now says say “Up”, right after Boot. And it stays that way. However, The built-in Internet Browser no longer connects.

    However, within the Network Setup Box, it is reported “not connected”. Nothing on my part seems to change this statement — - -

    What settings should go into this Network Setup Box and it’s various pulldown menu’s ?

    Is “Ethernet Up” different to “Network Connected” ?

    Thanks
    Ken

    * *

  • June 21, 2013 at 4:31 am |

    Thanks for posting again, Ken. Can you pastebin​.com your ifconfig?

  • Ken
    June 23, 2013 at 2:15 pm |

    Testing.

  • Ken
    June 23, 2013 at 2:19 pm |

    Hi Dru

    Been difficult to post here but it works this am.

    I pasted the _ifconfig that was resident in my pc-bsd machine, as requested.

    It’s call IFCONFIG_4_D and I posted it early on the 23rd. How will U find it ? It should be unlisted = = =

    There were 3 items with the name “_IFCONFIG” ;

    - This script,
    – an exe,
    and
    – a zip looking folder.

    Regards
    Ken

    * *

    • July 9, 2013 at 3:38 pm |

      Can you try pasting your ifconfig again? It should give you an URL that you can paste here.

Leave a comment

*

Please leave these two fields as-is:

Help the Project, Donate Today!