Nov
12

Second 10-STABLE Image Available for Testing

Kris has announced the availability of the next 10.0 testing image:

The second PC-BSD 10-STABLE image is now available for download!

Disclaimer:

This image is a very early cut of the new stable/10 branch of FreeBSD and is probably only suitable for advanced users or developers. A PKGNG repository is available for this release, however it is missing a number of packages we would normally ship with, such as virtualbox drivers, KDE accessories, etc. The AppCafe currently has only a few items in it for testing, but more will be added soon.

NOTE: Users of the previous 10-STABLE image may not be able to online-update, due to a bug in FreeBSD Update.

New Features:

  • Includes FreeBSD 10-STABLE / 10.0-BETA3 from 11/8/2013
  • Switched to PCDM as the default login manager
  • New 10.X artwork & themes
  • Fixed a long list of bugs relating to PBIs
  • Fixed issues enabling the flash plugin out of box
  • Corrected some installation issues via the text-installer
  • Corrected an issue changing passwords via the User Manager
  • Other misc bugfixes

10-STABLE notable features:

  • Updated KMS / AMD driver support
  • ISO file is a hybrid USB file, and can be “dd“ed to a USB media.
  • New text-based installer
  • New UEFI loader on installation media
  • Able to select between GRUB/BSD loaders during installation
  • And much more!

Reporting Issues:

Found a bug? Please report it, in as much detail as possible, to our Trac database.

Share This Post:
  • Digg
  • Facebook
  • Twitter
  • email
  • LinkedIn
  • Slashdot

Written by dru. Posted in 10.0, new features, testers

Trackback from your site.

Comments (50)

  • Jack
    November 12, 2013 at 12:24 pm |

    Control Panel > Package Manager (Advanced View) > Add remove Packages > Loading… Please Wait … CRASH!
    / Same thing as on PC-BSD v. 9.2

    • November 12, 2013 at 12:27 pm |

      I can’t reproduce this on either 9.2 or this 10 image. Is this an upgrade or fresh install? VM or hardware? Which window manager? Is this the only app that is crashing for you?

  • November 12, 2013 at 12:50 pm |

    9.2 was on hardware; 10 on VirtualBox, both with LXDE, fresh install.
    I installed this last version of v.10 on VBox because previous version 10 (I think from 24 Oct.) was impossible to install on same hardware that is used for v. 9.2 (I can try v.10-last-one later on real HDD )
    All other seems to work good.
    Hardware: AMD Phenom II X4, 8 GB Ram, NVIDIA GTX 760, SATA HDD 250

  • Jack
    November 12, 2013 at 1:03 pm |

    Launched from lxdeterminal :
    user@pcbsd-10vbox~% pc-su pc-pkgmanager
    Locale: “en“
    Starting metaWidget
    Searching for pkgs…
    QProcess: Destroyed while process is still running.

    • November 14, 2013 at 7:17 am |

      We’re not sure why this is happening. Please let us know if the issue persists once you are able to do a fresh install on real hardware.

  • anderson
    November 12, 2013 at 1:12 pm |

    Hardware: Asus K45VM nvidia GT630M-2GB

    VMWARE-PLAYER

    nvidia driver= fail 100%.
    intel gpu= fail 100%.

    VMWARE tool installed.

    nv driver:
    ntpd_initres[1882]: host name not found: 0/1/2.freebsd.pool.ntp.org

    KDE-lite instalation
    GPT=OFF
    4K=OFF
    GRUB

    • anderson
      November 12, 2013 at 1:55 pm |

      network is OK now, but nv driver fail

      VESA video

      intel/intel3d/nvidi/nv = fail

      • November 12, 2013 at 1:57 pm |

        We can reproduce the nvidia bug and Kris should have a fix for it tonight. Thanks for the heads up!

      • anderson
        November 14, 2013 at 10:55 am |

        after the update shows the message:

        ata1: FAILURE — zero length DMA transfer attempted

        for nv/nvidia/intel/intel3D fails
        video driver: vesa

        my OS is Windows 7 basic, VMWARE-PLAYER, Asus K45VM nvidia GT630M-2GB

        network is OK: NAT.

  • November 12, 2013 at 1:47 pm |

    > Able to select between GRUB/BSD loaders during installation

    Does chosing BSD loader enable one to use beadm?

    • November 12, 2013 at 1:56 pm |

      Nope, as the FreeBSD boot code doesn’t support it yet. GRUB is needed until it does.

      • November 13, 2013 at 3:16 am |

        Thank you.

        Considering I can experiment with my 2nd machine (netbook) and test 10.0 a bit, I wonder whether it will be possible to cleanly upgrade later — iow. no change in BSD loader’s size — in order to get required functionality when it will become available?

        • November 13, 2013 at 6:05 am |

          Upgrading from an earlier 10.x should be trivial. Kris is working on upgrade shims for 9.x to 10.x.

  • Jack
    November 12, 2013 at 2:13 pm |

    Managed to get it work;
    It seems like that it is important to have Update Manager closed, but still pkgmanager works every fifth attempt (aprox.)
    Tomorow will try install on real hardware.
    Thanks

  • abdelmalek
    November 12, 2013 at 2:17 pm |

    why i don’t obtain the pacbsd-9.2 on 32bit

  • Alptekin SANLI
    November 12, 2013 at 6:23 pm |

    I’m ‘testing’ (playing with) the latest release on VBox. One thing I’ve realized is that YouTube videos have the audio playing at a higher pitch; the video itself seems to be normal.

    • November 13, 2013 at 6:26 am |

      Interesting… Which browser?

      • Alptekin SANLI
        November 13, 2013 at 8:08 am |

        The browser is Firefox, with no add-ons except vimperator. Also: it’s not only YouTube videos, but also H.264 files opened directly on Firefox which have this problem.

        • Ken Moore
          November 13, 2013 at 1:16 pm |

          Alptekin SANLI » I have run into this before and it is directly related to the VirtualBox sound-card emulation. If you install PC-BSD on real hardware the sound will be perfectly fine.

  • […] Leer Mas […]

  • Dmitry
    November 14, 2013 at 10:55 am |

    hello
    Processor AMD Athlon 240
    NVidia 8500 graphics card

    [allgear@pcbsd] ~% uname –a
    FreeBSD pcbsd 10-STABLE-p3 FreeBSD 10-STABLE-p3 #0: Mon Nov 11 18:46:04 UTC 2013 root@amd64-builder.pcbsd.org:/usr/obj/usr/src/sys/GENERIC amd64

    lost language (Russian)
    Flash Player does not work (Opera, FireFox)
    not installed Sensories-applet

    5 errors generated.
    gmake[3]: *** [sensors-applet.o] Error 1
    gmake[3]: Leaving directory ‘/usr/ports/sysutils/sensors-applet/work/sensors-applet-1.6.1/src’
    gmake[2]: *** [all] Error 2
    gmake[2]: Leaving directory ‘/usr/ports/sysutils/sensors-applet/work/sensors-applet-1.6.1/src’
    gmake[1]: *** [all-recursive] Error 1
    gmake[1]: Leaving directory ‘/usr/ports/sysutils/sensors-applet/work/sensors-applet-1.6.1
    ===> Compilation failed unexpectedly.
    Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
    the maintainer.
    *** Error code 1

    Stop.
    make: stopped in /usr/ports/sysutils/sensors-applet

    does not work gksu nautilus

    • November 15, 2013 at 6:17 am |

      We’ll look into the sensors-applet and nautilus issues. Some ports still aren’t working in 10.

      Running “flashpluginctl on” as the user should fix flash.

      Regarding the Russian, if you select it at login is anything translated or are just some translations missing? Russian is currently showing as 43% translated at pootle​.pcbsd​.org.

      • Dmitry
        November 15, 2013 at 1:00 pm |

        I installed the version of 24 October, the localization was in place, update — reboot, localization disappeared completely.

        • November 18, 2013 at 6:46 am |

          Thanks for the heads up re: localization. We are looking into the cause.

  • Dmitry
    November 14, 2013 at 11:34 am |

    added: Nvidia driver does not work (reboot) is included NV

    • November 14, 2013 at 11:38 am |

      Correct, there is a known issue with this driver in this image.

  • Boumali
    November 15, 2013 at 10:49 am |

    Hi, sir
    I have the following propertiesofmy laptop: Dell inspiron 15 R
    7,8 GiB of memory
    Intel® Core™ i7-3517U CPU @ 1.90GHz × 4 processor
    Intel® Ivybridge Mobile x86/MMX/SSE2 graphics

    i have try to install pcbsd-9.2, but i have a crash in the beginin.
    where is the problem
    thank’s

    • November 18, 2013 at 6:59 am |

      Best to start a thread at forums​.pcbsd​.org so users can help you troubleshoot. Post the thread URL here.

  • sender
    November 17, 2013 at 4:49 am |

    Please add an option for password protected ZFS Encryption for / and /swap in the installer during partition.

    • November 18, 2013 at 6:05 am |

      Please create a feature request at trac​.pcbsd​.org and post the bug number here.

  • Jack
    November 17, 2013 at 6:24 am |

    v.10@real hardware: Package Manager (Advanced View) = Sometimes works, sometimes not; usually crash @ first three attempts, than one successful.
    BTW, is there an option to explicitly disable IPV6? Some distros, as I remember OpenSuSE 12.3 require adding parameter to GRUB.…

    Also on rebooting, console message:
    ata1 Failure — zero lenght DMA transfer attempted… seting up DMA failed

    And on login window Regional and Keyboard set is not working

    • November 18, 2013 at 7:06 am |

      Is the DMA just a warning or does it prevent PC-BSD from loading?

      • Jack
        November 20, 2013 at 12:16 am |

        Just warning that does not prevent PC-BSD from booting. Also, when I press Ctrl-Alt-F1, I get full screen of repeating that message.

        BTW I disabled IPV6 by adding to /etc/rc.conf and commenting out

        • Jack
          November 20, 2013 at 12:19 am |

          ~disabled IPV6 by adding ipv6_enable=“NO” to /etc/rc.conf and commenting out # ifconfig_re0_ipv6=“inet6 accept_rtadv”

  • vt
    November 17, 2013 at 11:17 am |

    Thinkpad x201 8gb ram lxde install
    Issues found:
    1 with wlan on and lan plugged in the system crashes upon boot. Wlan switch off suppresses the problem
    2 keyboard ‘language’ setting at logon does not work its always us
    3 pbis cant be downloaded
    4 ipv6 cant be disabled
    5 sudoed controlpanel apps dont work. With correct pw it always logs sth like ‘incorrect pw was entered three times’
    Hope you can fix those soon as id like to test further but given the issues above the system is no fun’using’..
    Thanks!!

    • vt
      November 17, 2013 at 11:57 am |

      Update: after a system update software downloads in the app cafe do work.
      The remainder of the issues still exist.

      • November 18, 2013 at 5:41 am |

        Thanks for the feedback! We’re looking into these issues.

        • vt
          November 29, 2013 at 9:33 am |

          Update (and Thanks for continued work!): last night I booted again and there are 159 packet updates. Unfortunately every attempt for installing them fails. Shall I send the log to someone or some mailing list? I know there’s a bug database but wonder if that would be appropriate.
          Please advise.

  • Brian Lee
    November 18, 2013 at 4:43 pm |

    i have tried installing the 64bit version 3 times on my AMD comp. When I try to do grub or grub slice, I get an error message that says installation failed because target or grub is not available. I can install the BSD loader or load it with no loader, but not with grub. Any idea why?

    • November 19, 2013 at 5:03 am |

      We would need a copy of the install config (installer gives an option to save this) for the failed install. If you post that in a bug report at trac​.pcbsd​.org, the devs can take a look at it.

  • shawn
    November 28, 2013 at 10:31 pm |

    I have been a long time user, love what you guys are doing with BSD. My only complaint about the new versions is why did the options for encrypted zfs get removed from installer? I loved that feature. every install gets a crypto zfs tank for /. I have searched high and low and cannot find an easy way to do this. Thanks for your time and effort in this project. I look forward to using this os more.

    • November 29, 2013 at 8:25 am |

      In the GUI, the ability to encrypt the underlying disks with GELI was replaced with the ability to encrypt, on a per-user basis, their home directory with PEFS.

      The GELI bits are still in the pc-sysinstall back-end if a user wants to script a GELI encrypted installation.

  • shawn
    December 2, 2013 at 1:40 am |

    thanks for the reply. i am working on making it easier. i wish for the ease of disk management during install. with all the installers for bsd and linux why hasn’t anyone written a webgui install. for nas bsd nas4free has the simplest disk management. creating raid arrays, zfs pools, GELI crypto. i liked the web interface for freenas until 9.x. it broke disk management features. what am i missing. other than learn cli for disk mgt.
    i have PC-BSD 9.1 running in production on a older hp xw9400 and it is a rock. so i really have no complaints on stable.

  • richard
    December 2, 2013 at 7:47 pm |

    1) I have a second disk on which I installed PC-BSD 10 so as to test ATI/AMD Drivers on three monitors.After installation and then booting up it blocks on the GRUB welcoming message i.e
    GRUB loading…

    Does anyone have an idea on how force it to boot.

    2) Is there a way to install the boot loader on the first disk and be able to boot PC-BSD on the second disk ?

    Thank you for help.

    • December 3, 2013 at 5:13 am |

      Please create a bug report at trac​.pcbsd​.org and post the bug number here. In your report, include /tmp/pc-sysinstall.log as it will contain the disk layout and how the installer stamped it.

    • December 6, 2013 at 5:49 am |

      Thanks!

  • abdelmalek
    January 2, 2014 at 5:05 am |

    Hi, sir
    I have the following propertiesofmy laptop: Dell inspiron 15 R
    7,8 GiB of memory
    Intel® Core™ i7-3517U CPU @ 1.90GHz × 4 processor
    Intel® Ivybridge Mobile x86/MMX/SSE2 graphics

    my question is:
    if characteristics are suitable for installing PC-BSD 10.
    best regards

    • January 3, 2014 at 6:28 am |

      You can always use the Hardware Compatibility icon in the first GUI menu of the installer to check for sure.

Leave a comment

*

Please leave these two fields as-is:

Help the Project, Donate Today!