Dec
17

End of the PKG woes

Hey everyone, I just wanted to let you know that the recent issues with package updates should be corrected with the new package set that just came out.

The graphical package manager will not be able to update to the new package set, instead you will need to run the following command manually:

sudo pkg upgrade

If this fails because of a package conflict, you will need to remove the offending package before trying the upgrade again. For instance, a number of user’s have had to run this command first:

sudo pkg remove –f py27-distribute-0.6.35

Once you have updated to the new package set, the graphical package utility will work perfectly fine again (since it got updated itself).

 

General background on the problem:

With the update of the new FreeBSD package utility (pkg) from 1.1.x ->1.2.x, there were a number of errors due to a bunch of backwards compatibility being missing in the new version. This meant that once you updated to the newer version you no longer had access to the packages on the PC-BSD repository (due to the changes in the repo format). Since our new 1.2.x packages were just released on the PC-BSD repo, you should now be able to continue changing your packages again. Another issue that came with 1.2.x was that a number of the utility flags all got changed suddenly — causing our graphical utility to need updating as well. We got that utility updated fairly quickly, but the updated package was in the new 1.2.x format — meaning that you have to use the command line to perform this one upgrade.

 

We are terribly sorry for the inconvenience. Please let us know here or on the forums if you run into any other issues.

Share This Post:
  • Digg
  • Facebook
  • Twitter
  • email
  • LinkedIn
  • Slashdot

Written by Ken Moore. Posted in 10.0, 9.2, pkgng

Trackback from your site.

Comments (11)

  • hsw
    December 17, 2013 at 8:11 pm |

    I just attempted to update the GUI package manager by:

    pkg –f update
    pkg remove –f py27-distribute-0.6.35
    pkg install pcbsd-utils-qt4

    Then used the GUI to review the remaining updates
    I have several locked packages, need to be sure that some dependency does not cause a conflict.

    Thanks Ken, now I have 9.2 successfully updated, and am looking forward to 10-STABLE packages updates.

  • Daemon
    December 18, 2013 at 4:10 am |

    Thanks for the clear instructions & explanation.

  • Ken Weeks
    December 18, 2013 at 1:03 pm |

    py-requests,Hi
    I have tried doing the update and get
    pkg: WARNING: locally installed py27-distribute-0.6.35 conflicts on /usr/local/lib/python2.7/site-packages/easy-install.pth.dist with:
    – py27-setuptools-1.1.7_1

    Running this command
    pkg remove –f py27-distribute-0.6.35

    Results in this message
    pkg: Error while trying to delete packages, dependencies that are still required:
    devel/py-distribute: www/py-requests, sysutils/pcbsd-utils, emulators/virtualbox-ose, sysutils/pcbsd-utils-qt4, misc/pcbsd-base
    –f does not seem to work
    I have also tried delete instead of remove with the same result.
    Also posted on the forum.
    Ken

    • Jonathan Noack
      December 18, 2013 at 2:04 pm |

      Looks like the website translated the hyphen-minus ( U+002D) into a dash of some sort. Retype the hyphen-minus and try again…

      • chris
        December 29, 2013 at 12:08 am |

        The hyphen is still in the original post. Took some minutes to figure this out.

  • Ken Weeks
    December 18, 2013 at 2:14 pm |

    Thank you Johnathon
    Best regards
    Ken

    • December 18, 2013 at 3:21 pm |

      Cheers! yes, it works now. that last did the trick.
      great work!

  • December 20, 2013 at 12:37 am |

    my trueOS 9-stable has nothing to update.

    pkg upgrade
    $ Updating repository catalogue
    $ Updating repository catalogue
    $ Nothing to do
    $ Cleaning up cache files..Done

    pc-updatemanager check
    $ Your system is up to date!

    pc-updatemanager pkgcheck
    $ Updating repository catalogue
    $ All packages are up to date!

    pkg search pkg
    $ pkg-1.1.4_1

    Any clues ?

    • Ken Moore
      December 20, 2013 at 7:22 am |

      mhafidz » The 9-STABLE branch has been obsolete for a while, since it was just the development branch for the 9.2 release. You will need to change branches over to the 9.2-RELEASE branch with the following commands first:

      (See what branches are available)
      pc-updatemanager branches

      (Move to the 9.2-RELEASE branch)
      sudo pc-updatemanager chbranch 9.2-RELEASE

      • December 20, 2013 at 8:50 am |

        Im on rolling release. Ken .. im confused now. I thought it will automatically updates itself.

        my uname –a

        FreeBSD demonyx 9-STABLE-p9 FreeBSD 9-STABLE-p9 #19 b6d4888: Mon Sep 9 17:47:25 EDT 2013 root@avenger:/usr/obj/pcbsd-build64-stable/fbsd-source/src/sys/GENERIC amd64

  • […] […]

Leave a comment

*

Please leave these two fields as-is:

Help the Project, Donate Today!