Dec
06

PC-BSD Weekly Feature Digest 12/6/13

It’s finally here!!  Earlier this week the PC-BSD team released a new test image for version 10.0.  Some of the exciting highlights were the addition of mate / gnome3/ cinnamon into the installer and package manager.   The linux compatibility layer has also been upgraded to the Linux Centos 6 compatibility layer which will be fantastic for the long run, but right now you may notice your internet browsers are not handling video properly in version 10.0.  We have new PBI’s on the way that should solve this problem and get your Youtube watching experience back up and running…I mean who wants to live in a world without Justin Bieber…am I right…??  OK put your hands down people that wasn’t a literal question!   Anyways I digress!  here is what’s going on in the PC-BSD universe this week.

We are trying to collect information on how all of you feel about the ease of use of installing a printer on PC-BSD.  We want to know the Good, the bad, and the ugly of your printer installation experience, including if you are having trouble finding a driver for your particular model of printer.   To participate in our poll for the next 2 weeks please go to: http://​forums​.pcbsd​.org/​s​h​o​w​t​h​r​e​a​d​.​p​h​p​?​t​=​21460

I am looking for users that are willing to test functionality of HPLIP (in package manager under drivers) while using non-HP printers.  More specifically if you have any brand of printer besides HP i’m looking for users that will add this package and see if it breaks or conflicts with your current printer’s setup.  Understand this is strictly volunteer and advanced users are recommended in case of any potential breakage.  PLEASE NOTE:  There is a known issue I ran into with Mate and the HPLIP package.  DO NOT install HPLIP right now while running mate or it will nuke your taskbar leaving you helpless to accomplish anything.  We are looking into a fix on this and hope to have one shortly.

We are well aware of the bugs corresponding to users with Grub as their boot manager for versions of 9.0 and 10.0.  While we believe we have isolated the issue we are still tracking down the root cause of the problem.  If you are experiencing problems with Grub please go to: http://​trac​.pcbsd​.org/​t​i​c​k​e​t​/​748 and add any thoughts or diagnostic information that might help us locate the problem.

On a similar note some of you will be glad to know that the ability to pick between the FreeBSD bootloader or the Grub boot loader has now been added back into the installer for version 10.0.  This may be especially helpful on systems that Grub is whining about booting from.

Many 10.0 PBI’s are finishing building over the weekend so you should see a pretty big influx of new PBI’s in the appcafe soon.  We will be systematically testing and working our way through them starting early next week.  EasyPBI is also receiving a big update for version 10, so some functionality may be missing or altogether not working for the time being.  Ken is planning on the updates being finished in the next week to be fully compatible with the 10.0 PBI system.

That’s it for this week folks.  Thanks for being a part of the PC-BSD community, and tune in next week for more exciting PC-BSD news!

P.S.  Just kidding on the date before the edit…Just wanted to make sure everyone was paying attention ;).

 

Share This Post:
  • Digg
  • Facebook
  • Twitter
  • email
  • LinkedIn
  • Slashdot

Written by Josh Smith. Posted in Uncategorized

Trackback from your site.

Comments (37)

  • cabpa
    December 6, 2013 at 8:48 pm |

    Thumbs up for developing printing usability, integrating gnome3, mate, cinnamon, and more PBIs

    • December 8, 2013 at 10:33 am |

      Thanks for the positive input cabpa!

  • Fred
    December 6, 2013 at 10:09 pm |

    No loving for KDE?

    • December 8, 2013 at 10:11 am |

      KDE has been included for some time now :).

      • Fred
        December 8, 2013 at 1:37 pm |

        As I didn’t see it mentioned in the post, I was afraid you had dropped support for it, replacing it with Mate, Gnome and Cinnamon. It’s doubly great if you are adding support for those _and_ keeping KDE too! :D

        • December 9, 2013 at 6:03 am |

          Oh I see what you mean now! Well just to be clear KDE will still be included.

  • anderson
    December 7, 2013 at 2:49 am |

    my issue is the BSD bootloader doesn’t runs. it stops halfway. shows only black screen.

    • December 8, 2013 at 10:13 am |

      Hey Anderson! We are aware of this issue and are actively looking into it now. Stay tuned to the blog next week for an update.

  • anderson
    December 7, 2013 at 12:07 pm |

    gnome should have more testers.

    • December 8, 2013 at 10:14 am |

      Can you be a little more specific? Are you having issues with Gnome 3? mate? If so please head on over to trac​.pcbsd​.org and let us know!

      • anderson
        December 9, 2013 at 10:30 am |

        Gnome3, man.

        i haven’t expertise for more info.

        There are many defects in gnome3, you need to draw more people to give operational support and report bugs.

        bugs I found are of type: click and nothing happens.

        I recommend joining up with the GhostBSD team, about gnome3.

      • anderson
        December 9, 2013 at 10:34 am |

        as I use a virtual machine, the problems I have can be even more severe than those that installs directly.

        gnome 3 in my case runs only in the fallback mode.

        • December 14, 2013 at 11:16 am |

          It works perfect for me in parallels, virtualbox, and natively. It’s normal for shell mode in freebsd not to work in virtualbox, paraelles. Shell mode in virtualbox only works in linux guest I think due to some missing gallium xorg related driver stuff if I recall correctly. You can blame me for adding it to unsupported desktops, and not supported desktops in the installer. The idea for that was so others would know it might have issues but i thought it would be better than no gnome 3 at all. :) If your having problems though please add it to trac​.pcbsd​.org so I can try to look into them also. GhostBSD doesn’t include Gnome3. I do work closely with the FreeBSD Gnome team however.

          • anderson
            December 15, 2013 at 5:56 am |

            gallium” is a software acceleration for 2D (uses CPU). I think half of my problem is due to no 2d acceleration. I use vmware to test the operating system, then it is possible that I am limited to problems in this environment. I will note some issues in vmware and try to list here.

            • December 15, 2013 at 8:18 am |

              If you read this page under the software rendering section it will explain why gnome-shell in virtualbox, kvm uses gallium.

              http://fedoraproject.org/wiki/Test_Day:201211-08_GNOME_3.6

            • December 21, 2013 at 7:28 pm |

              youtube.comI stand corrected. Gnome-shell should be possible. Here is a video showing it in action with some instructions on how to do it.

              • December 21, 2013 at 7:30 pm |

                For some reason the post ate my link and just displayed the video. :) Here are the instructions.

                press alt + f2, or open a terminal and run gnome-shell –replace

              • anderson
                December 24, 2013 at 11:17 am |

                the software renderer failed here. clutter don‘t works.

                /su
                /home/adm# gnome-shell –replace
                Xlib: extension GLX missing on display 0.0

                GModule-CRITICAL :gboolean g_module_close(GModule): assertion ‘module->ref_count> 0‘ failed

                Clutter-CRITICAL : Unable to initialize Clutter: Failed to connected to any renderer due to constraints.

                Window manager error: Unable to initialize Clutter.

  • mohmad
    December 8, 2013 at 10:04 am |

    I’m sad sad sad„,
    Why can not the printer driver canon-LBP6000B
    Prepare for the optical scanner Canon LiDE 110 also does not work
    At the same time (I have another printer — ricoh-1035 works easily)
    Why the system does not support hardware and old computers„, it’s not fair„,

    Why does not support this system of Arabic well, especially with regard to programming office and why I can not add lines of Microsoft Office non-free (as is the case in the system upuntu)

    I want good support for the program wein so I can run Photoshop

    Regards

    Mohammad from Egypt

    • December 8, 2013 at 10:29 am |

      My understanding is that the LBP6000B is a very new printer is that correct? If that’s the case it’s always better to go with tried and true models that support BSD. Since BSD is a close cousin to unix-like operating systems, (but not a linux)Linux software does not necessarily work out of the box. I have had success in the past by adding my printer by going to openprinting​.org and selecting my printer model and downloading a .ppd file from there to install my driver. If you are interested the closest thing I could fine to your model was the 5975. Might be worth a shot though. Glad your Ricoh printer is working well. They have a nice history of working well with BSD.

      As for support for Arabic that is a another story. Arabic has only received about 34% of the necessary translations to be complete and is in desperate need of review. If this is something you might be interested in helping with we have a nice online graphical interface to help assist with translating strings of text from english to arabic for you. Any changes you make can be committed to future versions of PC-BSD. For more information please contact me at Joshms@pcbsd.org and I can point you in the right direction.

      I’m not sure I understand your last question about adding lines of microsoft office. Can you try to clarify what you are looking to accomplish?

      Best Regards,

      Josh

  • mohmad
    December 8, 2013 at 12:30 pm |

    Dear brother
    Mr. / Josh esteemed God bless you
    I am a photographer , and I’m not well versed in technical matters and software , all of it ( I believe in the principles of the BSD license as well as all licenses similar to the free software and open source ) , and I am trying so hard to be this great system is my first choice , is the system basic desktop I have, and I ‘m trying to deploy this system between friends and family and neighbors ( whenever you can ) .

    Initial ** important thing , is that the latest version of the system does not support old computers 32 bit„ and that is a major dilemma , where you try to install the system on a neighbor’s computer and I could not by the fact that Old Computer (somewhat ) so I did install the older version and installation was successful , but the vital question , (why not support the latest version gear with regard to old computers ) , and how the system can be deployed between ordinary citizens and users of the poor? ?

    * Regarding the printer CANON-LBP6000B — not modern as you think , , is present in two years or more , , , ,

    * With regard to how to add that printer I wish to send me Graphics explain to me how to do this , God bless you , as I’m not a specialist , and I am not versed in the English language and what I can not understand and communicate with you well, as I sit Balsaotain so I write this letter to you
    * ( Is there a support cell in Arabic? ? ?) , , ,

    * Also the case with the device Scanner canon-LiDE –110 — does not work on the system

    * Support for the Arabic language , just wish that Libaoffice program supports the Arabic language , and non– free lines ( coming from Microsoft ) as is the case with Linux

    * Some of my friends ( those interested in matters of programming — and volunteers novice programmers ) have tried to assist in the project arab-BSD„ which was led by an Egyptian named Dr. programmer . Mohammed Faraj , but they quickly m surprised by the death of the project without reasons , ( Do you have information on this matter ) -

    * The last question in the letter the past : I wanted to be more support for the program (Wine)„ as was the case in the old version , so I can ( using Adobe Photoshop ) , , , and I hope to be supporting this application by default where I Photographer , ,

    * Boot loader also does not work in the latest version , does not see any Onzh running other than Windows (in the sense that he does not see Linux ) Why ?

    Thank you very much and Otmy you luck , ,

    * I hope that does not rush the release of this version , and I hope to slow the coders in the release of this version to be processed all the problems that have already been referred to in my those

    Greetings to all of you , , , God Bless

    Mohammed from Egypt occupied , , ,

    • Ian Robinson
      December 9, 2013 at 2:15 pm |

      Mohmad –

      You can run an earlier version of PCBSD on 32 bit computers. For an x86 (i386) PCBSD Version 9.1 download, go to:

      http://​iso​.cdn​.pcbsd​.org/​9​.​1​/​i​386/

      As an alternative to WINE, PCBSD offers VirtualBox in an easy to install PBI (Look in the App Cafe program on the desktop). If you have a Windows operating system, you can install it as a “machine” (i.e., a “computer”) in Virtual Box. Then you can install and run Photo Shop, etc.

      Ian Robinson
      Salem, Ohio, U.S.

  • December 12, 2013 at 10:08 pm |

    […] PCBSD weekly digest […]

  • Claive Alvin P. Acedilla
    December 13, 2013 at 7:56 am |

    Thumbs up not only for usability development for for printing hardware support because users need a lot of printing

  • anderson
    December 15, 2013 at 11:09 am |

    machine: ASUS K45VM core-i7 3610qm/8GiB Ram/750GiB HDD/Geforce GT 630M/windows 7basic 64bits

    PCBSD10-STABLE-x64-DVD-USB-latest (downloaded at: 15-DEC-2013)

    New and Clear installation

    VMWARE settings:
    –memory= 4GiB
    –HDD= 50GiB
    –processors= 6 with Intel VT-x ON (virtualize CPU performance counters OFF)
    –Network adapter= NAT
    3D acceleration graphics= ON
    –battery= report ON (works in the Gnome3)

    PCBSD options:
    –Gnome3
    –ZFS= default
    –GRUB= ON
    –vesa graphics

    Chromium browser installed and works, but shortcut resides in the Places>Desktop only.

    fails applications (won’t work:click and nothing happens):
    –CHEESE WEBCAM– don’t opens
    –VIDEOS– don’t opens

    GAMES:
    –NIBBLES: don’t opens

    System Settings (don’t opens, nothing):
    –BRIGHTNESS&LOCK
    –DATE&TIME
    –DETAILS
    –DISPLAYS
    –KEYBOARD
    –MOUSE&TOUCHPAD
    –ONLINE ACCOUNTS
    –POWER
    –PRINTERS
    –REGION & LANGUAGE
    –SOUND
    –UNIVERSAL ACCESS
    –USER ACCOUNTS

    • anderson
      December 15, 2013 at 11:32 am |

      update> chromium shortcut shows where i reboot sistem on the applications>internet menu

      • anderson
        December 17, 2013 at 12:53 pm |

        then Chromium shortcut appears when I restart the system.

    • anderson
      December 15, 2013 at 11:41 am |

      Graphics Feature Status
      –Canvas: Software only, hardware acceleration unavailable
      –Compositing: Software only, hardware acceleration unavailable
      3D CSS: Unavailable. Hardware acceleration unavailable
      –CSS Animation: Software only, hardware acceleration unavailable
      –WebGL: Unavailable. Hardware acceleration unavailable
      –WebGL multisampling: Unavailable. Hardware acceleration unavailable
      –Flash 3D: Unavailable. Hardware acceleration unavailable
      –Flash Stage3D: Unavailable. Hardware acceleration unavailable
      –Flash Stage3D Baseline profile: Unavailable. Hardware acceleration unavailable
      –Texture Sharing: Unavailable. Hardware acceleration unavailable
      –Video Decode: Software only, hardware acceleration unavailable
      –Video: Software only, hardware acceleration unavailable

      Problems Detected
      –GPU process was unable to boot: GPU process launch failed.
      –GL driver is software rendered. Accelerated compositing is disabled.: 59302
      –Mesa drivers in linux older than 7.11 are assumed to be buggy.
      –Accelerated 2d canvas is unstable in Linux at the moment.
      –ATI/AMD cards with older drivers in Linux are crash-prone.: 95934, 94973, 136240
      –ATI/AMD cards with third-party drivers in Linux are crash-prone.: 95934, 94973
      –ATI/AMD cards with third-party drivers in Linux are crash-prone.: 95934, 94973
      –Stage3D is not supported on Linux.: 129848
      –Accelerated video decode is unavailable on Mac and Linux.: 137247, 133828
      –Disable VMware software renderer.: 145531

      Driver Bug Workarounds
      clear_alpha_in_readpixels
      set_texture_filter_before_generating_mipmap
      Version Information
      Data exported 12/15/2013 5:37:07 PM
      Chrome version Chrome/31.0.1650.57
      Operating system FreeBSD 10-STABLE-p4
      Software rendering list version 6.11
      Driver bug list version 2.22
      ANGLE revision 2446
      2D graphics backend Skia
      Driver Information
      Initialization time 0
      Sandboxed false
      GPU0 VENDOR = 0x0000, DEVICE= 0x0000
      Optimus false
      AMD switchable false
      Driver vendor
      Driver version
      Driver date
      Pixel shader version
      Vertex shader version
      Machine model
      GL version
      GL_VENDOR
      GL_RENDERER
      GL_VERSION
      GL_EXTENSIONS
      Window system binding vendor
      Window system binding version
      Window system binding extensions
      Reset notification strategy 0x0000
      Log Messages
      [31407:272655360:1215/173643:ERROR:gl_surface_glx.cc(408)] : glxQueryVersion failed
      [31407:272655360:1215/173643:ERROR:gl_surface_x11.cc(58)] : GLSurfaceGLX::InitializeOneOff failed.
      GpuProcessHostUIShim:

      • anderson
        December 15, 2013 at 11:42 am |

        this is chrome://gpu/ report

      • anderson
        December 20, 2013 at 11:52 am |

        now with PCBSD10-STABLE-p6-1216-2013-x64-DVD-USB.iso

        same problems.

        • Josh Smith
          December 20, 2013 at 4:38 pm |

          Hey Anderson,

          One of the best ways of making sure your bugs are seen by the developers is to create a ticket at trac​.pcbsd​.org. I know some of the things you brought up have been or are being addressed, but it never hurts to have all the information in our central bug reporting repository so the dev’s can easily access the information. Especially since some of them may not read the blog :).

          Best Regards,

          Josh

  • anderson
    December 15, 2013 at 11:47 am |

    haven‘t openoffice

    • Josh Smith
      December 20, 2013 at 4:39 pm |

      If you find a program that is not included out of the box you can also make a feature request at trac​.pcbsd​.org by creating a ticket and selecting “feature request” in the drop down box for type of ticket. Thanks!

  • adSky
    December 19, 2013 at 10:43 am |

    Клинике разработку в сторону поддержки сенсорных экранов и планетой на новых процессорах от Intel.

Leave a comment

*

Please leave these two fields as-is:

Help the Project, Donate Today!